With apologies for being so trivial, I noticed a new user selecting “Create part from part” thinking that it is just like duplication and not realizing that there’s an inheritance relationship. It might help if it were named something like “Create derived part” or “Create inherited part”.
Hit another one: “Annotate…” is quite general. What about “Renumber…” or “Renumber reference designators…” or “Renumber parts…” or something else?
“Create derived part” is indeed much better.
It’s also called that way in Altium and KiCad. As far as I’m aware this is standard industry terminology.
OK, not a problem, though perhaps you’ll agree that annotate here seems like a fair case of nerdview.