Currently, if I assign alternate pin names and enable more than one name for a pin on a schematic symbol, all the pin names are concatenated with almost no separation between them (in the example below, pin 11 has primary
GPIO8 and alternate
SPI1_RX pin names):
The more common way I’ve seen this done elsewhere is to separate the different function names with
I don’t have a particular strong opinion on this topic. Dunno if slashes add too much visual noise. I suggest trying out various options by patching horizon/schematic_symbol.cpp at master · horizon-eda/horizon · GitHub and the following methods and seeing what’s best.
Good point! I actually tried a bunch of things and in absence of available characters like middle dot (
·) or bullet (
•), the only thing that looked a bit better was two spaces instead of one.
The hershey font we use has more glyphs than are currently made available as unicode codepoints. See the PDF linked in Forgive me, A V Hershey … – We Saw a Chicken … for a list of all glyphs. If you find anything that’s useful add it in horizon/text_data.cpp at master · horizon-eda/horizon · GitHub
@lukas oh nice - thanks for that.
I tried it with middle dot (
·) with and without surrounding spaces:
I think the one with surrounding spaces is easier to read. It’s however a bit wider.
I opened a PR for this.